Icon View Thread

The following is the text of the current message along with any replies.
Messages 1 to 10 of 36 total
Thread Dataset load response error
Sun, Nov 8 2015 9:36 AMPermanent Link

Riaz

Hi,

i am trying again with ewb, played with ewb1 now ewb2

i have a problem with the following error

Error: Dataset load response error ( cannot connect to server)

this works ok http://epos4u.4irc.com:6005/datasets?method=rows&dataset=butts

i am using the following, had it working on ewb1

Database.BaseURL:='http://epos4u.4irc.com:6005/datasets?method=rows&dataset=butts';
Database.Loadrows(mybutts);

the ewbsrvr is on my spare pc

many thanks,
Riaz
Sun, Nov 8 2015 10:23 AMPermanent Link

squiffy

Telemix Ltd.

Avatar

I think your issue is the need to open the dataset :

Database.BaseURL:='http://epos4u.4irc.com:6005/datasets?method=rows&dataset=butts';
mybutts.Open;
Database.Loadrows(mybutts);

before you load the rows.
Sun, Nov 8 2015 10:28 AMPermanent Link

squiffy

Telemix Ltd.

Avatar

Forget that - doesn't make any difference.
Sun, Nov 8 2015 10:36 AMPermanent Link

squiffy

Telemix Ltd.

Avatar

Could it be a cross origin block?
Sun, Nov 8 2015 11:00 AMPermanent Link

Riaz

squiffy wrote:

Could it be a cross origin block?


thanks for prompt replies, tried the cross origin, still same error

i had it working in ewb1

will keep trying unless someone can solve and give an example so i know where i am going wrong

Thanks
Sun, Nov 8 2015 11:07 AMPermanent Link

squiffy

Telemix Ltd.

Avatar

I tried it here and couldn't get passed the cross origin block. If you could add the appropriate headers to your server I'd be happy to test further.
Sun, Nov 8 2015 11:15 AMPermanent Link

Riaz

squiffy wrote:

I tried it here and couldn't get passed the cross origin block. If you could add the appropriate headers to your server I'd be happy to test further.


thanks for reply back,

i have no idea how to add headers etc,

this cross origin seems to be a nightmare for me

thanks for your help squiffy
Sun, Nov 8 2015 11:27 AMPermanent Link

Uli Becker

Riaz,

try this:

Database.BaseURL:='http://epos4u.4irc.com:6005/datasets';
Database.Loadrows(mybutts);

From the help:

property BaseURL: String
Usage

Specifies the base URL used when loading datasets with the LoadRows
method. The default value is "datasets".

Uli
Sun, Nov 8 2015 11:40 AMPermanent Link

squiffy

Telemix Ltd.

Avatar

Sorry I can't help further, but I don't use ewbserver (I use either php or B4J as the back end). I'm not even 100% sure what it is...

The xsite origin stuff drove me mad for ages. All I can recommend is that you confirm if that's the issue by running the JS console on your browser. The error will show there. If it does show you need to set  

Access-Control-Allow-Origin : *

somehow, but that will require someone who knows about ewbserver to help.

Good luck.
Sun, Nov 8 2015 11:46 AMPermanent Link

Riaz

Hi Uli,

thanks for the reply,  tried that, still same error

even put the html on a test server still the same

http://www.epos4bars.com/riaz/project1.html

this ewbsrvr seems to be a nightmare for me connecting a DBIsam database

all i want is the ewbsrvr to be running one my pc here connected to my router
been playing around with it and still stuck on the first level

Tim should seriously do some youtube videos for newbies like me, been waiting for these videos for nearly 2 years lol

Riaz
Page 1 of 4Next Page
Jump to Page:  1 2 3 4
Image