Icon View Thread

The following is the text of the current message along with any replies.
Messages 1 to 3 of 3 total
Thread Dataset load response error on new machine
Sat, Jun 13 2015 12:55 PMPermanent Link

David Martin

I have a pretty simple EWB web app that connects to a single DBISAM table. All works well on the computer it was developed on (running from either the IDE or via the EWB server using localhost). I moved it to another computer which one day will act as the web server. When I now run it on the second computer using localhost, it loads showing the appropriate grid but no data show in the grid and I get an Application Error dialog box with message:

Dataset load response error (Cannot connect to server) Line: 1.

I cannot figure out why this is occurring. I am using a local DBISAM table which can be previewed from the EWB server so the server can read the data. It should not matter, but the directory structure is the exact same for both computers so the output and data directories are the same and the files being used are all the same. In other words, for this project computer 2 is essentially a clone of computer 1.

Any pointers on what might be happening would much appreciated.

David Martin
Sat, Jun 13 2015 2:41 PMPermanent Link

Raul

Globestar Systems

Team Elevate Team Elevate

On 6/13/2015 12:55 PM, David Martin wrote:
> Dataset load response error (Cannot connect to server) Line: 1.
> I cannot figure out why this is occurring. I am using a local DBISAM table which can be previewed from the EWB server so the server can read the data. It should not matter, but the directory structure is the exact same for both computers so the output and data directories are the same and the files being used are all the same. In other words, for this project computer 2 is essentially a clone of computer 1.
> Any pointers on what might be happening would much appreciated.

Couple of things :

1. Can you access the EWB web server data direct with the browser ?

URL if you use defaults would be :
http://localhost/datasets?method=rows&dataset=<your dataset name>

(for example http://localhost/datasets?method=rows&dataset=Albums for
the albums example)

2. Are you serving the EWB app also from the same EWB web server? If not
then make sure "Enable Cross-Origin Resource Sharing" is enabled in the
web server settings on content tab)

3. Use the browser debug tools to see what's happening underneath if you
still have problems - in terms of actual URL generated, any browser
errors that are not surfaced etc.

Raul

Sat, Jun 13 2015 7:46 PMPermanent Link

David Martin

Thank you Raul for your input.

<<1. Can you access the EWB web server data direct with the browser ?>>

No. From machine 1 where all works, I do get the data back (as either a page refresh or as a datasets.json file).  From machine 2, I do not get anything as far as I can tell. (I get a webpage cannot be found 404 error and never get a message asking me to save or open "datasets.json" as I can get from machine 1.)

<<2. Are you serving the EWB app also from the same EWB web server?>>

Yes. I did check "Enable Cross-Origin Resource Sharing" in the web server to see if made a difference and it did not.

<<3. Use the browser debug tools to see what's happening underneath if you
still have problems - in terms of actual URL generated, any browser
errors that are not surfaced etc.>>

Using browser debug tools is beyond my scope of knowledge.

It seemed to me that the problem I have been getting would occur if I misspelled the dataset name which I entered manually on machine 2. Before I sent the original post, I checked multiple times to make sure the dataset names matched on the different web servers. Because that would be really dumb.

Well, I made a misspelling that I could only see when I got closer to the monitor (a large screen TV!). Although I have not tried it yet, I am sure all will work when I change "Reseacrh_Dataset" to "Research_Dataset" on web server 2. Sorry if I wasted anybody's time, but I did find Raul's input quite helpful to better understand how EWB works. So thanks again Raul.

David Martin
Image