Icon View Thread

The following is the text of the current message along with any replies.
Messages 1 to 6 of 6 total
Thread Elevate Web Builder 3 Beta Build 13 is Now Available
Fri, May 8 2020 2:30 PMPermanent Link

Tim Young [Elevate Software]

Elevate Software, Inc.

Avatar

Email timyoung@elevatesoft.com

I've uploaded Build 13 of the beta.  Some quick notes:

- There is a new TMailer component for sending email from server-side applications (the release notes didn't get updated in the builds, so ignore the part about this missing).  I haven't tested it completely, especially multi-part MIME messages (attachments, alternative views), but I have tested sending basic messages using GMail's SMTP gateway (smtp.gmail.com) without issue.  If you want to try this with GMail, remember that you'll need to turn on 2-step verification under the Security section of your Google account, and then add an app password for use with the SMTP gateway (the user name will be your GMail email address).  If you use port 587, then the defaults for the TMailer component will be adequate (port 587, security level of security with TLS upgrade).  Here is some example code:

procedure TReqHandler1.SendMail(Request: TWebServerRequest);
var
  TempEmailAddress: Variant;
begin
  with Request do
     begin
     TempEmailAddress:=Request.RequestParameters['Address'];
     with Mailer1 do
        begin
        Host:='smtp.gmail.com';
        UserName:='<GMail Email Address>';
        Password:='<Google App Password>';
        MailFrom:='"User Name" <user@gmail.com>';
        MailTo.Add('"Another User Name" <anotheruser@mydomain.com>');
        MailSubject:='Test Email';
        MailMessage:='This is a test email to make sure that everything works okay !!!';
        Execute;
        end;
     SetResponseNoCacheHeader;
     if (Mailer1.StatusCode=SMTP_CLOSING) then
        SendContent('Email sent successfully')
     else
        SendContent('Email send failed:'+CRLF+Mailer1.Transcript.Text);
     end;
end;

I dropped a TMailer component on a server application request handler designer surface and used it in the code.

- There was a compiler issue that caused the JS emitting to skip emitting necessary code, and this was exacerbated by the code assistance feature.  This should now be fixed, but please let me know if you still see anything weird happening.

- The 64-bit EWB Web Server should be working okay now.  There was an issue with the internal spin lock implementation that prevented it from starting up properly in the last few builds.

- There are bunch of small fixes to the IDE, including fixes to the code assistance and the search/replace functionality.

I'll be doing an overview video soon, but I really need to finish up the BLOB handling for the server-side database access and get some remaining RTL functions added for file/directory manager, as well as encryption and base-64 encoding/decoding.

Thanks !

Tim Young
Elevate Software
www.elevatesoft.com
Fri, May 8 2020 6:58 PMPermanent Link

Riaz

Hi Tim,
with this latest build most of the library are missing, tried rebuild library and nothing happens

Riaz
Fri, May 8 2020 7:23 PMPermanent Link

Riaz

ignore. its working now after re-installing again
Fri, May 8 2020 7:28 PMPermanent Link

Riaz

TMailer component not present

Riaz
Fri, May 8 2020 7:31 PMPermanent Link

Raul

Globestar Systems

Team Elevate Team Elevate

On 5/8/2020 7:28 PM, Riaz wrote:
> TMailer component not present

It's a server component and i have it with build 13

Raul
Fri, May 8 2020 7:34 PMPermanent Link

Riaz

Raul wrote:

On 5/8/2020 7:28 PM, Riaz wrote:
> TMailer component not present

It's a server component and i have it with build 13

Raul


Thanks, it showing now after restarting
Image