Icon View Thread

The following is the text of the current message along with any replies.
Messages 11 to 17 of 17 total
Thread Clean installation of EWB3 and error with the external web server.
Thu, May 14 2020 1:08 PMPermanent Link

Alvaro

Tim:
I did it !, on the PC with Win10. I'm going to review what I did to put it down for reference and I want you to see it; and how was the installation of the certificate. I think there was the problem
Now I am going to test, doing the same settings on the PC with Win7.
Thank you and I will comment on how I am doing.

Alvaro
Thu, May 14 2020 4:04 PMPermanent Link

Tim Young [Elevate Software]

Elevate Software, Inc.

Avatar

Email timyoung@elevatesoft.com

Alvaro,

<< I did it !, on the PC with Win10. I'm going to review what I did to put it down for reference and I want you to see it; and how was the installation of the certificate. I think there was the problem
Now I am going to test, doing the same settings on the PC with Win7.
Thank you and I will comment on how I am doing. >>

Fantastic !  Please let me know if you have any further issues.

Tim Young
Elevate Software
www.elevatesoft.com
Thu, May 14 2020 6:07 PMPermanent Link

Alvaro

Tim:
Finally I was able to run EWB3 and ewbsrvr.exe (32) on Win7 Pro (where I had started testing).
Initialize the certificate stores (something I have never done before), check the Windows registry, check TLS 1.0 and higher and it is active, uninstall the entire EWB3 environment, and start again.

Copy as reference the installation of Win10, content of ewbsrvr.ini, and server configuration in the IDE, finally I was able to make the whole environment work in Win7.
Opening Win10 ports 80/443, and from the Win7 browser, I can run an EWB application:

Win7 browser:http://192.168.250.206/test.htmlIn
Win10 (local):http://localhost/test.html.

And here I ask a new question:
When I try to run under port 443, the browser returns this error:

"Cannot connect securely to this page
This could be because the site uses outdated or unsafe TLS security settings.
If the problem continues, try to contact the owner of the website. "

This is typing in the Win10 browser:
https://localhost/test.html or localhost:443/test.html
and in the Win7 browser, the same thing happens too:
https://192.168.250.206/test.html or 192.168.250.206:443/test.html

What can happen or what do I need to configure?

I don't know how to indicate inside the IDE, test a 443 connection.

Content of the ewbsrvr.ini over Win10:

[Server]
Server Name=EWBSRVR
Server Description=Elevate Web Builder 3 Web Server
Database Directory=c:\EWBServer300\www
Max Database Write Delay=5
Domain=
Enable Cross Origin Resources=0
Keep-Alive Resource Name=keepalive
Authentication Resource Name=authentication
Administration Resource Name=administration
Databases Resource Name=databases
Modules Resource Name=modules
Applications Resource Name=applications
Debugger Resource Name=debugger
Logs Resource Name=logs

Max Database Write Delay=5

Default Document=
Content Directory=c:\EWBServer300\www\content
Application Directory=c:\EWBServer300\www\applications
Module Directory=c:\EWBServer300\www\modules
Logs Directory=c:\EWBServer300\www\logs

IP Address=
Port=80
Secure Port=443
Timeout=30
Max Request Size=16777216
Authorized Addresses=*

Blocked Addresses=
Thread Cache Size=128
Max Num Threads=2048
Max Authentication Attempts=10
Authentication Lockout Time=300
Session ID Length=32
Session Expiration=1800
Password Salt Length=16
Password Hash Type=0
Certificate Name=
Certificate Store Name=
Certificate Store Type=1

Thank you
Alvaro
Fri, May 15 2020 5:04 PMPermanent Link

Tim Young [Elevate Software]

Elevate Software, Inc.

Avatar

Email timyoung@elevatesoft.com

Alvaro,

<< When I try to run under port 443, the browser returns this error: >>

I'm looking into this issue.  I originally tested the TLS implementation using a real certificate, and forgot to test it with a self-signed localhost certificate, so I'm trying to figure out what needs to change to make it work.  I'll let you know as soon as I know something more.

<< I don't know how to indicate inside the IDE, test a 443 connection.  >>

In the Server Manager, double-click on the Internal server name and then set the Base URL to:

https://localhost

and that will cause the EWB IDE to use a secure connection for all requests to the internal web server (this also applies to any other server defined in the Server Manager).

Tim Young
Elevate Software
www.elevatesoft.com
Fri, May 15 2020 9:02 PMPermanent Link

Alvaro

Tim Young [Elevate Software] wrote:

<<In the Server Manager, double-click on the Internal server name and then set the Base URL to:

https://localhost>>

Thanks Tim, I just tried the Base URL inside the IDE:

http://localhost   by   https://localhost.

I get the an error. Also the IDE hangs and I also see that the ewbide.ini is not updated regarding this change.
Base URL continue set as http://localhost.
I have attached a screenshot of the error.
Internal server has port: 8080 and secure port: 443 set.
Alvaro



Attachments: Idehttpserror.JPG
Fri, May 15 2020 9:04 PMPermanent Link

Alvaro

Tim:
I made a mistake the parameters, they are: 8081 and 443.

Alvaro
Sun, May 17 2020 11:47 AMPermanent Link

Tim Young [Elevate Software]

Elevate Software, Inc.

Avatar

Email timyoung@elevatesoft.com

Alvaro,

<< I get the an error. Also the IDE hangs and I also see that the ewbide.ini is not updated regarding this change. >>

Yes, I'm still looking into the https issue, so it won't work for now.

Tim Young
Elevate Software
www.elevatesoft.com
Previous PagePage 2 of 2
Jump to Page:  1 2
Image