Icon View Thread

The following is the text of the current message along with any replies.
Messages 1 to 6 of 6 total
Thread onKeyPress crash
Thu, Dec 6 2012 12:55 PMPermanent Link

pedrini.franck

Axima srl


 We want use onKeypress on tedit for use 'Enter' press
 this code send the browser in crash when i press enter

function TForm1.Edit1KeyPress(Sender: TObject; Key: Char; ShiftKey, CtrlKey, AltKey: Boolean): Boolean;
begin     
    if key <> #13 then  label1.caption:=key;
end

Why ?


Thank you
Thu, Dec 6 2012 1:40 PMPermanent Link

Raul

Globestar Systems

Team Elevate Team Elevate

Works OK here with v 1.0.1 build 2 - what version of EWB are you using.

Also you should set the Result:=true if you want the key to show up in
edit fields (IE seems to always show it but others not).

e.g.
if key <> #13 then  label1.caption:=key;
result:=true;

Raul

On 12/6/2012 12:55 PM, pedrini.franck wrote:
> if key <> #13 then  label1.caption:=key;
Thu, Dec 6 2012 3:13 PMPermanent Link

pedrini.franck

Axima srl


 Hello raul

 my version is 1.01 Build2  (commercial version)

I test
if key <> #13 then  label1.caption:=key;
result:=true;
run F9
but when i press enter the EWB enter in "not responding" mode , i must use taskmanager for kill EWB



Thu, Dec 6 2012 3:46 PMPermanent Link

Peter

>  but when i press enter the EWB enter in "not responding"
> mode , i must use taskmanager for kill EWB

take a look at this posting:

http://www.elevatesoft.com/forums?action=view&category=ewb&id=ewb_general&page=1&msg=1469#1469

Greetings ... Peter



---
Sorry for my weird english
Thu, Dec 6 2012 7:05 PMPermanent Link

pedrini.franck

Axima srl


hello peter

 For me is not the same problems. I have  deploy the project on iis7 and browser firebird.(tested also mac/safari , mac/chrome)
 example :
 function TForm1.Edit1KeyPress(Sender: TObject; Key: Char; ShiftKey, CtrlKey, AltKey: Boolean): Boolean;
begin     
   if key <> #13 then  label1.caption:=key else label1.caption:='ok';
  result:=true;
end;

when i press enter nothing does not happen in label1

--
also my English is strange!

Tue, Dec 11 2012 12:37 AMPermanent Link

Tim Young [Elevate Software]

Elevate Software, Inc.

Avatar

Email timyoung@elevatesoft.com

Franck,

<< For me is not the same problems. I have  deploy the project on iis7 and
browser firebird.(tested also mac/safari , mac/chrome)  example :  >>

Please send me a project that reproduces this issue, and I'll be happy to
take a look and see what is going on.

Thanks,

Tim Young
Elevate Software
www.elevatesoft.com
Image