Icon View Thread

The following is the text of the current message along with any replies.
Messages 1 to 10 of 19 total
Thread First CD Collector Database Application Demo
Thu, Jan 26 2012 5:42 AMPermanent Link

Tim Young [Elevate Software]

Elevate Software, Inc.

Avatar

Email timyoung@elevatesoft.com

I finally have the first CD Collector demonstration application up on the
web site here:

http://www.elevatesoft.com/cdcollector/cdcollector.html

It's read-only and very basic, but shows you how you would go about putting
together a data-aware application very quickly.  The back-end web server is
the Elevate Software Web Server, and it has been updated to provide basic
JSON data services for the demo applications on the web site.

Attached you will find the source code to the demo application, along with a
new copy of the GlossyBlue theme that is used with the application.  You
will need to install the theme before opening the application in the IDE, or
else the application theme will revert to the default and won't look very
good.

Please let me know if you see any issues when running the application on
your end.

Enjoy !

--
Tim Young
Elevate Software
www.elevatesoft.com





Attachments: cdcollector.zip
Thu, Jan 26 2012 8:14 PMPermanent Link

Steve Gill

Avatar

Looks great Tim.  Thanks for the source too.
Sat, Jan 28 2012 1:31 PMPermanent Link

Fernando Dias

Team Elevate Team Elevate

Tim,

Awesome!
It really looks good, and very useful to show how Datasets work at the client side.
Now, what's in the server side? Where is the data coming from?

--
Fernando Dias
[Team Elevate]
Sat, Jan 28 2012 1:53 PMPermanent Link

Fernando Dias

Team Elevate Team Elevate

Hey,

Just to make sure everyone is managing to run the demo with live data from Tim's server you have to replace :
  TempRequest.URL:='data\'+DataSet.Name;

with
  TempRequest.URL:='http://www.elevatesoft.com/cdcollector/data/'+DataSet.Name;

in the TMainForm.LoadDataSet method.

--
Fernando Dias
[Team Elevate]
Sun, Jan 29 2012 2:11 PMPermanent Link

Jan Ferguson

Data Software Solutions, Inc.

Team Elevate Team Elevate

Hi Tim,

I compiled the CD Collector project and made the change to the code
that Fernando stated in his post in this thread. However when I run the
project on my server I get an error:

Application Error
uncaught exception: Error
line: 0

I have to click the OK button three times to get past the error. After
clicking the OK button to get rid of the error message I do not get any
data in the project. The rest of the project works perfectly...just no
data. Is the code that Fernando mentioned (copied below) correct or am
I missing something?

TempRequest.url: =
'http://www.elevatesoft.com/cdcollector/data/'+DataSet.Name;


--
Jan Ferguson





Attachments: CDCollectorError.jpg
Sun, Jan 29 2012 2:12 PMPermanent Link

Jan Ferguson

Data Software Solutions, Inc.

Team Elevate Team Elevate

Tim,

I forgot to mention that I am running the January 26th build.

--
Jan


Sun, Jan 29 2012 2:26 PMPermanent Link

Fernando Dias

Team Elevate Team Elevate

Jan,

Do you also get the exception if you stop the internal web server ?

--
Fernando Dias
[Team Elevate]
Sun, Jan 29 2012 2:41 PMPermanent Link

Jan Ferguson

Data Software Solutions, Inc.

Team Elevate Team Elevate

Fernando,

I am not running the internal web server. I get an error message when I
try to start it on my development computer:

The web server cannot be started (Socket error: An attempt was made to
access a socket in a way forbidden by it's access permissions. (10013),
on API 'bind')

Due to that I never try to run my test projects with the internal web
server. I upload them to my web server and they have all run properly.

However...on a lark I decided to try to run this project (F9) and when
I did, it did indeed run and it did show the data properly. I double
checked and the internal web server is not running.

FWIW, the web server I am running the demo on is a Unix box, but I
can't see where that would make any difference.

--
Jan


Fernando Dias wrote:

> Jan,
>
> Do you also get the exception if you stop the internal web server ?
Sun, Jan 29 2012 4:37 PMPermanent Link

Fernando Dias

Team Elevate Team Elevate

Jan,

I just uploaded it to my web server and I'm also seeing the same issue.
It doesn't happen with Elevate web server or directly in the browser, though.
It seems we will have to wait for Tim... I have no idea what is causing it, unless it is related with another issue that I have seen, when the server runs in a machine with the regional settings set to other than English, but I really don't know if its related or not.

--
Fernando Dias
[Team Elevate]
Sun, Jan 29 2012 4:38 PMPermanent Link

Raul

Globestar Systems

Team Elevate Team Elevate

I'm thinking it's the JS same origin policy issue - your web server serves the JS files which then attempt to access elevate web site which would not be permitted.

Raul

<<
FWIW, the web server I am running the demo on is a Unix box, but I
can't see where that would make any difference.
>>
Page 1 of 2Next Page
Jump to Page:  1 2
Image