Icon View Thread

The following is the text of the current message along with any replies.
Messages 11 to 14 of 14 total
Thread Strange behaviour of Local Web Server
Sat, Jun 21 2014 6:53 AMPermanent Link

Doc

Matthew Jones wrote:
How can you possibly see it if EWB is not running? Close the IDE and see if
you can see it from Chrome. If so, then there is another server running.

No, I can only see http://localhost/test.html from Chrome (or other browser) if EWB ist running and Local Web Server is started. But I cannot see it within EWB.
So, EWB is working but can only display the form from the local file on my HD, Local Web Server is working and I can see my form from a browser, but EWB cannot display the form when Local Web Server is started. There is NO other Web Server.
Very strange.
Sun, Jul 6 2014 10:41 AMPermanent Link

Doc

I did some extra testing and found out:

If I go to Internet Settings (Windows 8.0, IE 10) and uncheck Activate DOM storage, I can see my form within EWB using the Local Web Server.
If I check this item I only get a blank screen.

Any ideas?
Mon, Jul 7 2014 4:21 AMPermanent Link

Matthew Jones

Doc wrote:

>  Activate DOM storage

Google tells me:

"The DOM Storage includes two related mechanisms for persisting
client-side data in a secure manner using the Document Object Model
(DOM), sessionStorage and localStorage. These objects were introduced
in Internet Explorer 8.DOM Storage is often compared to HTTP cookies.
Like cookies, Web developers can store per-session or domain-specific
data as name/value pairs on the client using DOM Storage. However,
unlike cookies, DOM Storage makes it easier to control how information
stored by one window is visible to another."

Thus it seems that this is not really related to general functioning of
an EWB application.

Do you actually use the localStorage or sessionStorage facilities in
your code? I know I do in some of my projects, but I have no idea why
it would affect anything. I guess one good thing is that it is working
for you sometimes. Most odd. Do you have any add-ins that might be
affecting it?

--

Matthew Jones
Mon, Jul 7 2014 9:23 AMPermanent Link

Doc

Thank you for your reply.

No, I don't use DOM storage in my project. I get the empty screen problem even with a blank test project.
Maybe it is a problem that only occurs with IE10 (and Windows 8.0), I couldn't get the 8.1 Update to install on my system. On another PC with Win 8.1 I don't see a problem with EWB.
Previous PagePage 2 of 2
Jump to Page:  1 2
Image