Icon View Thread

The following is the text of the current message along with any replies.
Messages 11 to 18 of 18 total
Thread Need help updating dataset based on query with params
Thu, Nov 6 2014 8:48 AMPermanent Link

Uli Becker

> The two date params get their values from two Edit controls on Form1.  The user enters the range of dates they wish to search and ds1 returns only that range of dates.

Unless I misunderstand the whole thing, you actually don't want to
*update* the ds1 dataset. You just want to "refresh" it with new date
range value (entered in edit fields on Form2).

If I'm right, then the right way would be to open Form2, let the user
enter the date range, read the begin- and end-date from the (unbound)
edit fields and reolad ds1 with these params.

Uli


Thu, Nov 6 2014 9:55 AMPermanent Link

TD

Advanced Data Systems, Inc.

Uli Becker wrote:

> The two date params get their values from two Edit controls on Form1.  The user enters the range of dates they wish to search and ds1 returns only that range of dates.

Unless I misunderstand the whole thing, you actually don't want to
*update* the ds1 dataset. You just want to "refresh" it with new date
range value (entered in edit fields on Form2).

If I'm right, then the right way would be to open Form2, let the user
enter the date range, read the begin- and end-date from the (unbound)
edit fields and reolad ds1 with these params.

Uli

I am very sorry for the confusion but no that is not what I am doing here.  

Form1 has the two Edits where the user enters the two dates that create the data range.  It is on Form1 that ds1 is refreshed to just show this range of  dates in Grid1 which is also on Form1.  After the user has the grid showing just the dates he wishes to see THEN he selects a row in the grid then clicks a button on Form1 which launches Form2 and it is on Form2 where he edits the selected row data.

It is when I click the SAVE button on Form2 that the error occurs.  BTW, all of the Edit's on Form2 are bound to ds1 which is on Form1.  Perhaps a picture of the two forms will help; see attached screen capture.

Thanks for hanging in there and helping Uli !
TD



Attachments: Form2.PNG
Thu, Nov 6 2014 2:01 PMPermanent Link

Uli Becker

OK, now I got it - the screenshot made it clear.

Unfortunately I can't help you, no idea why a simple update produces
that error. It looks like an empty "Incident Date", but that doesn't
seem to be the case.

Probably opening a support ticket will provide a quick solution.

Uli
Thu, Nov 6 2014 3:47 PMPermanent Link

Raul

Globestar Systems

Team Elevate Team Elevate

On 11/2/2014 1:57 PM, TD wrote:
> How can I make this work?  The error message I get is attached.

TD,

The error is EDB one so the request did make it to back-end server (when
you commited the transaction on Form2 ) so have you used the browser
debug tools to see what the actual request looks like that went back
(url itself as well as payload json) ?

That would be good place to start in terms of seeing if the sql etc
looks ok.

Raul

Thu, Nov 6 2014 9:15 PMPermanent Link

TD

Advanced Data Systems, Inc.

Raul wrote:

On 11/2/2014 1:57 PM, TD wrote:
> How can I make this work?  The error message I get is attached.

TD,

The error is EDB one so the request did make it to back-end server (when
you commited the transaction on Form2 ) so have you used the browser
debug tools to see what the actual request looks like that went back
(url itself as well as payload json) ?

That would be good place to start in terms of seeing if the sql etc
looks ok.

Raul

I am running the app from within the EWB IDE.  Which debug tools are you referring to?  

Thanks for trying to help,
TD
Fri, Nov 7 2014 3:53 AMPermanent Link

Matthew Jones

TD wrote:

>  Which debug tools are you referring to?

Good browsers have developer tools that allow you to see the traffic
back and forth. In Chrome, press F12, and all will be revealed.

--

Matthew Jones
Fri, Nov 7 2014 8:31 AMPermanent Link

Raul

Globestar Systems

Team Elevate Team Elevate

On 11/7/2014 3:53 AM, Matthew Jones wrote:
>>   Which debug tools are you referring to?
>
> Good browsers have developer tools that allow you to see the traffic
> back and forth. In Chrome, press F12, and all will be revealed.
>

AFAIk you can't access them within EWB IDE but just access your from the
browser (URL is shown in IDE when you run it) and then use the tools in
the browser.

Raul
Fri, Nov 7 2014 9:52 AMPermanent Link

TD

Advanced Data Systems, Inc.

Thanks guys, I'll try that and report back.

Thanks for the help!
TD
Previous PagePage 2 of 2
Jump to Page:  1 2
Image