Icon View Thread

The following is the text of the current message along with any replies.
Messages 1 to 7 of 7 total
Thread ElevateDB - Plunge Taken - Help Me Get Going?
Thu, Apr 28 2016 10:00 AMPermanent Link

Mark Brooks

Slikware

Avatar

All

I have been using EWB pretty much since day one as a hugely effective tool for adding slick web clients to existing REST APIs. For a number of reasons, the time has now come to build a new solution where I will also be responsible for the database, web server and API.

I am keen to use as many Elevate products as possible because a) they "just work" b) I have a good understanding of EWB already c) I love Object Pascal and d) the support and forums are awesome. In another time, long ago, I also used DBISAM very effectively.

Based on what I need to build I have decided to utilise EWB + EWB Web Server (for now) + ElevateDB. My immediate issue is a lack of working time with the later two. So, I've had my first day and successfully:

- Downloaded the ElevateDB demo
- Got it running in CS mode
- Created a database
- Created a table (called Contacts)
- Added some date
- Got Elevate WS running (on the same machine)
- Created a connection to the EDB table
- Pointed it to the output folder for a test EWB project

I can happily visit the test project via localhost:8888/Test.html

However I was expecting to get some JSON back from the web server via localhost:8888/datasets?method=rows&dataset=Contacts (where Contacts is the name of my table)

Anybody drop me a hint to get past this bit of the puzzle?

Regards
Mark
Thu, Apr 28 2016 12:28 PMPermanent Link

Raul

Globestar Systems

Team Elevate Team Elevate

On 4/28/2016 10:00 AM, Mark Brooks wrote:
> However I was expecting to get some JSON back from the web server via localhost:8888/datasets?method=rows&dataset=Contacts (where Contacts is the name of my table)
> Anybody drop me a hint to get past this bit of the puzzle?

Yes this should work.

Few things to check
1. In EWS when you edit your dataset and switch to Preview tab - do you
see data ?

2. make sure in URL that you use the EWS dataset name (and not
necessarily the table name).

Not related to this but if your EWS and data are on the same server you
do not need to use CS connection but can use local one.



I can confirm in my case i have a EWS dataset called Customers and
following URL results in JSON in the browser :
http://localhost:6005/datasets?method=rows&dataset=Customers

Raul
Fri, Apr 29 2016 7:00 AMPermanent Link

Mark Brooks

Slikware

Avatar

Raul wrote:

>>I can confirm in my case i have a EWS dataset called Customers and
>>following URL results in JSON in the browser :
>>http://localhost:6005/datasets?method=rows&dataset=Customers

Raul

Thanks for the input. I can see the data in the EWS connection preview but the URL provides no JSON. Incidentally, I don't see data in the IDE either if I configure the dataset, drop on a form and hook up a grid. Why am I so stupid!

Mark
Fri, Apr 29 2016 12:55 PMPermanent Link

Tim Young [Elevate Software]

Elevate Software, Inc.

Avatar

Email timyoung@elevatesoft.com

Mark,

<< However I was expecting to get some JSON back from the web server via localhost:8888/datasets?method=rows&dataset=Contacts (where Contacts is the name of my table) >>

If you're using the external EWB Web Server, then you need to make sure that you have the Contacts dataset defined on the web server (in addition to the EWB IDE).

See here for more info:

http://www.elevatesoft.com/manual?action=viewtopic&id=ewb2&topic=Configuring_Server

under "DataSets".

Tim Young
Elevate Software
www.elevatesoft.com
Sat, Apr 30 2016 7:54 AMPermanent Link

Mark Brooks

Slikware

Avatar

Tim / Raul

Thanks for your help. I can now get JSON via the browser as expected.

No luck in the IDE as yet. Am I expecting to see live data at design-time when I drag a dataset onto a form and hook-up a grid?

Cheers
Mark
Sat, Apr 30 2016 10:19 AMPermanent Link

Raul

Globestar Systems

Team Elevate Team Elevate

On 4/30/2016 7:54 AM, Mark Brooks wrote:
> No luck in the IDE as yet. Am I expecting to see live data at design-time when I drag a dataset onto a form and hook-up a grid?

There is no live data at design time. Design time you will see columns
etc but no data.

Raul
Sat, Apr 30 2016 1:51 PMPermanent Link

Mark Brooks

Slikware

Avatar

>>Raul wrote:
>>There is no live data at design time. Design time you will see columns
>>etc but no data.

Whew- that's good news - onwards (and thanks again)
Image