Icon View Thread

The following is the text of the current message along with any replies.
Messages 1 to 2 of 2 total
Thread Can't load package on starging Delphi.
Thu, Jul 12 2018 12:33 PMPermanent Link

R.G.

I just installed (4.45 build 4) 445b4dbisamvclstddelphi7.exe into D7 on a Win10 machine. It seemed to install properly but every time I start Delphi I get an error pop-up saying the following:

Can't load package C:\Lang\Delphi7\TP\dbisam\db\code\dbisamd445delphi7.bpl.
The specified module could not be found.
Do you want to attempt to load this package the next time the package is loaded?

I click yes and then go into to menu options Components / Install Packages. I scroll scroll down to the now unchecked "DBISAM Design-Time Package" and try to check the checkbox and get the same pop-up. However, if I select the "Add" button and reselect the .bpl the package is installed and everything works properly ... until the next time I restart Delphi.

-- Same behavior if I say to the pop-up and add the package.

-- I've tried my preferred directory as in the error message but for testing I also tried installing in the default directory. Same results.

-- The path to the .bpl is properly included in the Library Path (and the Browsing Path).

--  I did not have this issue with my older (4.26 build 3) install in the same location.

Any thoughts as to what might be going on and how to fix it?
Tue, Jul 17 2018 12:34 PMPermanent Link

Tim Young [Elevate Software]

Elevate Software, Inc.

Avatar

Email timyoung@elevatesoft.com

Robert,

Resolved per email: the issue was a custom BPL directory for Delphi 7.

Tim Young
Elevate Software
www.elevatesoft.com
Image