Icon View Thread

The following is the text of the current message along with any replies.
Messages 1 to 7 of 7 total
Thread custom file extensions with ODBC
Mon, Jul 2 2012 9:26 AMPermanent Link

John Taylor

I am trying to connect via ODBC in VS2010 to dbisam tables where I have
customized the file extensions to
..sfdata, .sfidx and .sfblb

As per the DBIsam ODBC docs, I have edited the registry entry in
HKLM\Software\ODBC\ODBCINST.INI\DBISAM 4 ODBC Driver to that the 'FileExtns'
date is "*.sfdata,*.sfidx,*.sfblb" (without the quotes)

In VS2010 I always get the message when trying to connect to the data 'Table
or backup file does not exist'.  If I change the file extensions
for the files in the database to .dat, .idx and .blb, everything works as
expected.

What else do I need to change in the registry to get this working with my
correct file extensions ?

I am using the trial version of the standard ODBC driver, just downloaded
from Elevate's site yesterday.

Do I need to reboot my system after changing the registry entry for the
'File Extns' ?  I think I did that yesterday, but will
try that again now.

John
Mon, Jul 2 2012 12:33 PMPermanent Link

John Taylor

I believe this is because I have not edited the FileExtns item in the
Wow6432Node registry hive !

Will try that

John

"John Taylor" <jcta@snappysoftware.com> wrote in message
news:FFDEB04F-6C80-4FD9-A586-19A3A2045B0F@news.elevatesoft.com...
> I am trying to connect via ODBC in VS2010 to dbisam tables where I have
> customized the file extensions to
> .sfdata, .sfidx and .sfblb
>
> As per the DBIsam ODBC docs, I have edited the registry entry in
> HKLM\Software\ODBC\ODBCINST.INI\DBISAM 4 ODBC Driver to that the
> 'FileExtns' date is "*.sfdata,*.sfidx,*.sfblb" (without the quotes)
>
> In VS2010 I always get the message when trying to connect to the data
> 'Table or backup file does not exist'.  If I change the file extensions
> for the files in the database to .dat, .idx and .blb, everything works as
> expected.
>
> What else do I need to change in the registry to get this working with my
> correct file extensions ?
>
> I am using the trial version of the standard ODBC driver, just downloaded
> from Elevate's site yesterday.
>
> Do I need to reboot my system after changing the registry entry for the
> 'File Extns' ?  I think I did that yesterday, but will
> try that again now.
>
> John
Mon, Jul 2 2012 1:08 PMPermanent Link

John Taylor

No resolution to this, the only solution I've found is to change the file
extensions (the files themselves) to .dat,.idx and .blb

John

"John Taylor" <jcta@snappysoftware.com> wrote in message
news:4A324660-20F3-43FB-823D-2DB8AF2628C8@news.elevatesoft.com...
> I believe this is because I have not edited the FileExtns item in the
> Wow6432Node registry hive !
>
> Will try that
>
> John
>
> "John Taylor" <jcta@snappysoftware.com> wrote in message
> news:FFDEB04F-6C80-4FD9-A586-19A3A2045B0F@news.elevatesoft.com...
>> I am trying to connect via ODBC in VS2010 to dbisam tables where I have
>> customized the file extensions to
>> .sfdata, .sfidx and .sfblb
>>
>> As per the DBIsam ODBC docs, I have edited the registry entry in
>> HKLM\Software\ODBC\ODBCINST.INI\DBISAM 4 ODBC Driver to that the
>> 'FileExtns' date is "*.sfdata,*.sfidx,*.sfblb" (without the quotes)
>>
>> In VS2010 I always get the message when trying to connect to the data
>> 'Table or backup file does not exist'.  If I change the file extensions
>> for the files in the database to .dat, .idx and .blb, everything works as
>> expected.
>>
>> What else do I need to change in the registry to get this working with my
>> correct file extensions ?
>>
>> I am using the trial version of the standard ODBC driver, just downloaded
>> from Elevate's site yesterday.
>>
>> Do I need to reboot my system after changing the registry entry for the
>> 'File Extns' ?  I think I did that yesterday, but will
>> try that again now.
>>
>> John
>
Mon, Jul 2 2012 2:02 PMPermanent Link

Raul

Globestar Systems

Team Elevate Team Elevate

John,

I suggest you contact elevate support directly as they will likely be
quickest way to get answers in this case.

I believe the dbisam odbc is 32bit as well so pretty sure you do need to
use the Wow6432Node for all the settings - this includes both
"ODBCINST.INI\<Driver Name>" section and "ODBCINST.INI\ODBC Drivers".

Raul

On 7/2/2012 1:08 PM, John Taylor wrote:
> No resolution to this, the only solution I've found is to change the
> file extensions (the files themselves) to .dat,.idx and .blb
>
> John
>
> "John Taylor" <jcta@snappysoftware.com> wrote in message
> news:4A324660-20F3-43FB-823D-2DB8AF2628C8@news.elevatesoft.com...
>> I believe this is because I have not edited the FileExtns item in the
>> Wow6432Node registry hive !
>>
>> Will try that
>>
>> John
>>
>> "John Taylor" <jcta@snappysoftware.com> wrote in message
>> news:FFDEB04F-6C80-4FD9-A586-19A3A2045B0F@news.elevatesoft.com...
>>> I am trying to connect via ODBC in VS2010 to dbisam tables where I
>>> have customized the file extensions to
>>> .sfdata, .sfidx and .sfblb
>>>
>>> As per the DBIsam ODBC docs, I have edited the registry entry in
>>> HKLM\Software\ODBC\ODBCINST.INI\DBISAM 4 ODBC Driver to that the
>>> 'FileExtns' date is "*.sfdata,*.sfidx,*.sfblb" (without the quotes)
>>>
>>> In VS2010 I always get the message when trying to connect to the data
>>> 'Table or backup file does not exist'.  If I change the file extensions
>>> for the files in the database to .dat, .idx and .blb, everything
>>> works as expected.
>>>
>>> What else do I need to change in the registry to get this working
>>> with my correct file extensions ?
>>>
>>> I am using the trial version of the standard ODBC driver, just
>>> downloaded from Elevate's site yesterday.
>>>
>>> Do I need to reboot my system after changing the registry entry for
>>> the 'File Extns' ?  I think I did that yesterday, but will
>>> try that again now.
>>>
>>> John
>>

Mon, Jul 2 2012 3:11 PMPermanent Link

John Taylor

Raul,

That's my next step, I've edited every instance in the registry related to
the odbc file extns but nothing works,
I'll contact support

John

"Raul" <raul@removethis.raul.ca> wrote in message
news:B10A9DF9-8A30-4F66-9B94-0C5355074863@news.elevatesoft.com...
> John,
>
> I suggest you contact elevate support directly as they will likely be
> quickest way to get answers in this case.
>
> I believe the dbisam odbc is 32bit as well so pretty sure you do need to
> use the Wow6432Node for all the settings - this includes both
> "ODBCINST.INI\<Driver Name>" section and "ODBCINST.INI\ODBC Drivers".
>
> Raul
>
> On 7/2/2012 1:08 PM, John Taylor wrote:
>> No resolution to this, the only solution I've found is to change the
>> file extensions (the files themselves) to .dat,.idx and .blb
>>
>> John
>>
>> "John Taylor" <jcta@snappysoftware.com> wrote in message
>> news:4A324660-20F3-43FB-823D-2DB8AF2628C8@news.elevatesoft.com...
>>> I believe this is because I have not edited the FileExtns item in the
>>> Wow6432Node registry hive !
>>>
>>> Will try that
>>>
>>> John
>>>
>>> "John Taylor" <jcta@snappysoftware.com> wrote in message
>>> news:FFDEB04F-6C80-4FD9-A586-19A3A2045B0F@news.elevatesoft.com...
>>>> I am trying to connect via ODBC in VS2010 to dbisam tables where I
>>>> have customized the file extensions to
>>>> .sfdata, .sfidx and .sfblb
>>>>
>>>> As per the DBIsam ODBC docs, I have edited the registry entry in
>>>> HKLM\Software\ODBC\ODBCINST.INI\DBISAM 4 ODBC Driver to that the
>>>> 'FileExtns' date is "*.sfdata,*.sfidx,*.sfblb" (without the quotes)
>>>>
>>>> In VS2010 I always get the message when trying to connect to the data
>>>> 'Table or backup file does not exist'.  If I change the file extensions
>>>> for the files in the database to .dat, .idx and .blb, everything
>>>> works as expected.
>>>>
>>>> What else do I need to change in the registry to get this working
>>>> with my correct file extensions ?
>>>>
>>>> I am using the trial version of the standard ODBC driver, just
>>>> downloaded from Elevate's site yesterday.
>>>>
>>>> Do I need to reboot my system after changing the registry entry for
>>>> the 'File Extns' ?  I think I did that yesterday, but will
>>>> try that again now.
>>>>
>>>> John
>>>
>
>
Tue, Jul 3 2012 8:22 AMPermanent Link

Tim Young [Elevate Software]

Elevate Software, Inc.

Avatar

Email timyoung@elevatesoft.com

John,

<< That's my next step, I've edited every instance in the registry related
to the odbc file extns but nothing works,I'll contact support >>

Resolved via email - needed to use the ODBC Configuration Utility provided
with the ODBC Driver.

Tim Young
Elevate Software
www.elevatesoft.com
Thu, Oct 2 2014 11:33 PMPermanent Link

Mauro D

Hi, I did This but I can't  create a linked DB in SQL Server, if I change the extension to .dat it works, but with .db4 is not working, I did everything  on this tread!!!

Eduardo

"Tim Young [Elevate Software]" wrote:

John,

<< That's my next step, I've edited every instance in the registry related
to the odbc file extns but nothing works,I'll contact support >>

Resolved via email - needed to use the ODBC Configuration Utility provided
with the ODBC Driver.

Tim Young
Elevate Software
www.elevatesoft.com
Image