Icon View Thread

The following is the text of the current message along with any replies.
Messages 1 to 10 of 11 total
Thread Unable To Display Web Page Hosted By EWB Web Server In VPS
Sun, Mar 4 2018 9:23 AMPermanent Link

Frederick Chin

I installed the EWB web server as a service in a VPS with Windows Server 2008 and in the Connections tab, I set the IP address to listen to "localhost" and the port as "8081".

The content folder is set to "c:\ewb\prg". and the HTML page is "restbook.html".

When I type the URL "localhost:8081/restbook.html" in the web browser in the VPS, I can see the web page.

However, when I try to connect to the VPS from an external computer with the URL of "<VPS IP address>:8081/restbook.html", I get a message that:

This site can’t be reached
103.91.64.16 took too long to respond.

There is no problem pinging the VPS's IP address.

I have created an incoming rule for the port 8081. I have even tried disabling the Public Profile of the firewall but I am still unable to display the web page.

Am I missing one or more settings?

--
Frederick
Sun, Mar 4 2018 11:04 AMPermanent Link

Matthew Jones

Dig deeper into the firewall. And open the port, don’t allow the exe as
that fails most times for me. Also the cloud providers usually have an
external firewall to be opened too (a good thing!).

And if you can, don’t be using Windows 2008 as it is way too old.

--
Matthew Jones
Sun, Mar 4 2018 3:22 PMPermanent Link

Walter Matte

Tactical Business Corporation

Check Firewall

Check that the folder with the database rights - for IIS is it iis_usr - you may need to give user Everyone rights - I am not sure.

I usually have 2 tests in my web server  - /test - which just returns the time - it lets me know the server is accessible.  then /testdb which will read a record in a table and respond with it - to show access to db.  ... I should have a third which does update - as this did get me once....(permissions to write)

Walter
Sun, Mar 4 2018 6:40 PMPermanent Link

Frederick Chin

Matthew and Walter,

Thanks for your replies.

I have managed to solve the problem by leaving the field for "Listen on IP Address" of the web server's connections tab, blank.

I discovered this accidentally after I called NETSTAT -AN at the VPS and found that port 8081 was being listened to from just one IP address, 127.0.0.1, while I noticed that the listening port for RDP is 0.0.0.0.

The permissions settings for the directory would only be necessary if this was a network access problem.

This is what happens when you don't use EWB enough. Smile

P.S.   As for using Windows Server 2008, I had no choice because my VPS was the basic package with 25GB disk space and the server uses 15GB. I also wanted to see how EWB would perform at the lowest RAM (512MB) and hard disk (10GB) configuration.

--
Frederick
Mon, Mar 5 2018 3:51 AMPermanent Link

Matthew Jones

Frederick Chin wrote:

> NETSTAT -AN

I use "netstat -ano" for some reason - and good catch. You were binding to a particular IP address, not all, and so it wasn't available to the external interface. I expect this will help others in future!

(Still no excuse for Windows 2008 - it ended support two years ago...)

--

Matthew Jones
Mon, Mar 5 2018 8:43 AMPermanent Link

Frederick Chin

"Matthew Jones" wrote:

/*
(Still no excuse for Windows 2008 - it ended support two years ago...)
*/

The vendor said that Windows Server 2016 would use 35GB of hard disk space. Ridiculous! If I had a choice, I'd just use Windows 10.

--
Frederick
Mon, Mar 5 2018 9:57 AMPermanent Link

Raul

Globestar Systems

Team Elevate Team Elevate

On 3/5/2018 3:51 AM, Matthew Jones wrote:
> Frederick Chin wrote:
>
> (Still no excuse for Windows 2008 - it ended support two years ago...)
>

If you mean original 2008 then yes but this is likely 2008R2 which has
extended support til 2020

Raul
Mon, Mar 5 2018 10:01 AMPermanent Link

Matthew Jones

Frederick Chin wrote:

> Windows Server 2016

And 2012? Nonetheless, it is a security risk. For a quick test, who cares. For production, or staging, don't consider it.

--

Matthew Jones
Mon, Mar 5 2018 10:03 AMPermanent Link

Raul

Globestar Systems

Team Elevate Team Elevate

On 3/4/2018 9:23 AM, Frederick Chin wrote:
> I installed the EWB web server as a service in a VPS with Windows Server 2008 and in the Connections tab, I set the IP address to listen to "localhost" and the port as "8081".

That would limit access to "Localhost" only - meaning you could only
access the EWB Web server from the same machine (using localhost or
127.0.0.1 IP).

Generally you only want to do something like this is when configuring a
database server. Idea is that database server is only locally accessible
by the web server while web server itself is internet accessible.
The only other scenario is when you use stunnel in which case stunnel is
bound to IP.

> When I type the URL "localhost:8081/restbook.html" in the web browser in the VPS, I can see the web page.

Correct


> However, when I try to connect to the VPS from an external computer with the URL of "<VPS IP address>:8081/restbook.html", I get a message that:
>
> This site can’t be reached
> 103.91.64.16 took too long to respond.

Correct - you limited server to localhost only and not its public IP so
it's not externally accessible

>
> Am I missing one or more settings?
>

You need to make it listen on actual IP or on 0.0.0.0 (which is all IPs)
- if you leave it blank it likely default to 0.0.0.0 internally

Raul
Mon, Mar 5 2018 1:36 PMPermanent Link

Raul

Globestar Systems

Team Elevate Team Elevate

On 3/5/2018 8:43 AM, Frederick Chin wrote:
>
> The vendor said that Windows Server 2016 would use 35GB of hard disk space. Ridiculous! If I had a choice, I'd just use Windows 10.
>

Sounds high.

I just looked at a test VM of 2012R2 we have and it's using 14GB
(including our app and data).

I would expect 2016 to be similar

Win10 is not licensed for this type of use and while one can install it
personally for anybody providing VPS service it's not an option legally.

Raul
Page 1 of 2Next Page »
Jump to Page:  1 2
Image