Icon View Incident Report

Minor Minor
Reported By: Mark Wilsdorf
Reported On: 1/24/2008
For: Version 4.26 Build 1
# 2577 Rebuilding DBSYS Utility Application Results in Compiler Error for DBISAMSV Unit

I remember seeing somewhere a comment that changes to DBSys might be required if built with other than Delphi 5. I'm having no success building it with BDS 2006. I encountered the error:

Unit dbisamsv was compiled with a different version of dbisamtb.EDBISAMEngineError


Comments Comments
The dbisamtb.pas unit is now supplied in its full form, complete with IFDEFs, in order to permit recompilation.


Resolution Resolution
Fixed Problem on 1/26/2008 in version 4.26 build 2


Products Affected Products Affected
DBISAM Additional Software and Utilities
DBISAM CLX Client-Server
DBISAM CLX Client-Server with Source
DBISAM CLX Standard
DBISAM CLX Standard with Source
DBISAM ODBC Client-Server
DBISAM ODBC Client-Server with Source
DBISAM ODBC Standard
DBISAM ODBC Standard with Source
DBISAM ODBC Trial
DBISAM VCL Client-Server
DBISAM VCL Client-Server with Source
DBISAM VCL Standard
DBISAM VCL Standard with Source
DBISAM VCL Trial

Image